GitStack 1.3 overwrites system path

The installer for GitStack 1.3 overwrite the system path environment variable. After installation completes, its value is replaced by: C:\bin\GitStack\python;C:\bin\GitStack\python\Scripts;C:\bin\GitStack\git\cmd I opted for “C:\bin\GitStack” instead of the proposed “C:\GitStack” for the installation directory. Target system is Windows 7 Professional SP1
asked March 29, 2012

4 Answers

I made the test on a clean Windows Server 2008 R2 (which is similar to Windows 7).
I installed GitStack 1.3, the PATH system variable was not replaced. After uninstallation, the PATH system variable was still correct.
I will test it on Windows 7 SP1 as soon as possible. Let me know if you have any insight on what could have been happen on your system.
I have no idea of what could have gone wrong on my system, the installation process was error-free. Here are the steps I performed:

(1) Installed GitStack 1.2 yesterday, played with it for a while.
(2) Noticed today that GitStack 1.3 was available, uninstalled 1.2 then installed 1.3.
(3) Tried to use an unrelated CLI exe located in C:\bin in PowerShell, got a 'file not found' error.
(4) Scratched my head.
(5) Looked at the system PATH, gasped in horror when I saw its contents.
(6) Used System Restore to go just before (1). Noticed that all the GitStack restore points have a description written in Chinese characters.
(7) Saved the contents of the system PATH in a text file.
(8) Installed GitStack a second time.
(9) Pasted the saved contents into the system PATH.
(10) Resumed playing with GitStack.

Forgive me if the following question is silly: did you check that the system PATH contained something before installing GitStack on your clean system ?

On the plus side, GitStack 1.3 now does exactly what I need: I can use it as a remote backup repository for the Xcode 4 projects on my development Mac. Thank you for your hard work.
Hi Nicolas,

I have installed today a fresh Windows 7 SP1.
1. I checked the original system path
2. I installed GitStack 1.2 (specific gitstack stuff was added to the path)
3. I uninstalled GitStack 1.2. The specific stuff was removed
4. I installed GitStack 1.3. The specific gitstack stuff was added
5. I uninstalled GitStack 1.3. The specific stuff was removed

I tried also to add some other path at the end of the system path + gitstack stuff and I did not encounter any issue.

That's really weird.

PS : I can reproduce the bug with the Chinese characters and I have created an entry in the issue tracker.
This issue is now fixed :

Your Answer

Please login to post questions.