Various errors encountered…


Using SmartGit on client, or git bash, i get same error.

error: Recv failure: Connection was reset while accessing http://user@ip/repo.git/info/refs fatal: HTTP request failed

Creating a repository doesn’t work for me. Using the web UI, I name a repo, click create, and i get an error saying it cannot find the file specified.

I had to browse to the folder named repositories, then create a folder in there. It would then list it as a repo. I used git bash, git init on that folder. Then it was giving me the option to import it. I imported it, and it was THEEEEN listed as a repository with options to browse it, and assign users.

I created a user, and assigned it to the repository. All good there. Clicked on browse and that gave me a php error.

Call to a member function (GetProject()) on a non-object ControllerBase.class.php line 99

And so far, that’s all the errors ive been getting.

I had wamp installed. I stopped all services, and uninstalled. Then installed gitstack over it. Could it be that a restart is due!?

asked June 4, 2012

4 Answers


New developments.

I haven't been able to commit/push in localhost yet.

However, after uninstalling everything and re-installing again, it worked with no errors. except that it is not doing much for me.

I create a repository now without issues, and users, assign them to the repo... no problem.

So i went to my desktop, created a folder, and navigated to it using git bash. I did a clone, and got the empty repository warning. It seems to have done "something" as a .git folder was created in my desktop folder i was testing on.

I then added a txt file to try to push to the empty repository i had just cloned nothing from.

It tells me:
fatal: not a git repository (or any of the parent directories): .git

On my client machine, I run git clone http://user@server_ip/repo.git and still get Recv failure. HTTP request failed, as stated in my previous post.

Seems I only managed to reestablish normal gitstack functionality, but I am missing something on git's inner workings...

Do you get any message in C:\GitStack\apache\logs\error.log ?
Thanks for your reply. I had already posted the info requested. But I also kept looking into the error myself. I found that I was running a version that didn't have the firewall fix that was fixed about 16 days ago today. It is now working perfectly. The Dev's here are hysterically happy. At least to run it in local network it has all we need. We noticed it is missing a Spanish translation. If you need help with that, we'd be glad to offer a hand with it. GitStack is truly a lifesaver. A great thing that I found this awesome tool when I did. Thanks for everything!
Thank you for using our software :)

Your Answer

Please login to post questions.